• last updated 9 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Rewrite idiom to be portable (limit is psql only)

prefer "ns_conn isconnected" over "ad_conn isconnected", since the latter might not notice changes in the connect state

  1. … 18 more files in changeset.
improve spelling: move closer to the linux documentation recommendations

  1. … 9 more files in changeset.
fix an at lease 11 year old bug... not sure, why this was not discovered earlier

Whitespace cleanup

use dot instead of colon as separator between package name and cache key to ease readability

  1. … 10 more files in changeset.
acs::per_thread_cache: standardize per-thread caching

- added per-thread cache based on namespaced Tcl variables.

- use per-thread-cache on several occasions

- bump version number of acs-tcl to 5.10.0d34

  1. … 14 more files in changeset.
Rename string_truncate and string_truncate_middle to comply with OpenACS naming convention, create deprecated wrappers, replace occurrences

As string_truncate_middle was defined in xotcl-request-monitor, bring it to acs-tcl instead

  1. … 11 more files in changeset.
Replace parse_incoming_email with ad_parse_incoming_email, replace occurrences

  1. … 1 more file in changeset.
improve spelling

  1. … 14 more files in changeset.
Reduce divergency between oracle and postgres codebase

improve comment

whitespace changes

Undeprecate and reimplement: require_admin_request, can_admin_request_p, require_notify_object and can_notify_object_p. Fixes in two templates (request-delete, request-change-frequency). (Many thanks to Felix Mödritscher for the patch!)

    • -16
    • +26
    ./notifications-security-procs.tcl
  1. … 1 more file in changeset.
Fix parameter name in proc doc

Deprecate 'notification::email::get_parameter', just a wrapper for 'parameter::get', used almost nowhere.

Fix variable name

Deprecate wrappers for 'permission::permission_p' and permission::require_permission.

Implement the Notifications Security Library procs... 16 years after their creation.

    • -18
    • +31
    ./notifications-security-procs.tcl
Reuse person API instead of querying by hand

Revert massive replacement of empty list creation sentences. The use of '[list]' instead of '{}' adds semantics that could be used for performance improvements in the future, such as using a different internal representation. There is already work in this direction, avoiding the generation of the string representation during comparison of empty strings (huge thanks to Stefan Sobernig for the pointer: https://core.tcl.tk/tcl/info/44527c632ed609c2).

  1. … 473 more files in changeset.
Replace 'linsert' with 'lappend'

Fix linsert command argument expansion + Whitespace

improve list operations

  1. … 5 more files in changeset.
Rework variable assignment (set -> lassign) + Whitespace changes

    • -50
    • +49
    ./notification-callback-procs.tcl
  1. … 17 more files in changeset.
unify spelling of URL

  1. … 3 more files in changeset.
Prefer '{}' to '[list]' when creating empty lists

  1. … 69 more files in changeset.
Rework variable assignment (set -> lassign) + Whitespace changes

Rework variable assignment (set -> lassign)

  1. … 11 more files in changeset.
Comment state of notification::type::get_type_id due to per-thread caching