antoniop in OpenACS

Quote the backslash as well...

Italian message keys for cookie-consent package

Revert reduction of divergency between oracle and postgres codebase:

this conflicts hard with downstream code and results in less scalable behavior

Use better idiom to retrieve the xowiki instance (also checking permissions)

Reduce divergency between oracle and postgres codebase

    • -0
    • +38
Remove reference to client, as now this is decided in the xowiki chat implementation

Fix string replace to render user link

Use a more scalable idiom to retrieve the first available xowiki instance

Force IE to recover focus on the message field whenever messages are rendered

Chat reform:

- rework xotcl-core chat machinery to return its responses through JSON and include information about active users

- depend on xowiki instead of xotcl-core only

- exploit xowiki "Comet" server push implementation when the browser supports it

- reduce code duplication

- drop plain HTML chat

- reduce hardcoded styling

- minor cleanups

    • -64
    • +16
    • -0
    • +12
    • -23
    • +5
    • -30
    • +0
    • -47
    • +0
    • -11
    • +4
    • -21
    • +3
    • -8
    • +1
    • -53
    • +0
    • -274
    • +0
    • -23
    • +22
  1. … 9 more files in changeset.
Converge render method for chat and xotcl-core package

Add ':' to formatting to uniform with the render method

Preliminary xowiki chat rework

- update javascript to comply with CSP (setInterval...)

- exploit template resource loading machinery to load javascripts

- remove code duplication

- remove inline styling

    • -95
    • +78
Unquote single quote from JSON before appending messages to chat

Fix quoting of single quotes in JSON

Remove leftover alert

Avoid javascript eval idiom as CSP will refuse to execute when unsafe-eval is disabled

This requires moving to a more approprate JSON parser... which is also pickier regarding single quotes, so I had to rework JSON encoding to please it.

Make ad_sanitize_html not hardly dependant on a connection being there (thanks to Markus moser for the report)

Also, update documentation and make idioms less awkward.

(this passes automated tests)

Better separate data from formatting

    • -1
    • +6
    • -9
    • +1
Normalize indentation

    • -19
    • +19
Decouple a bit formatting from data

    • -0
    • +48
    • -26
    • +6
Give templating a chance

move all hardcoded styling to the adp template, which might be styled by the theme. Also, biring some order in the login proc, e.g. don't open and read a file to include a javascript all the time.

    • -64
    • +59
Modernize XoTcl idioms

Remove smelly comment, as parameter is there

Deprecate util_search_list_of_lists, as since Tcl 8.5 its behavior can be achieved natively through lsearch

Modernize tcl

Whitespace removal

Move image::get_info together with its pals procs in the content repository... just to realize it should probably go away at some point

    • -42
    • +0
Fix layout when no data for test is available

Fix typo in doc