gustafn in OpenACS

Bring files on oacs-5-10 in sync with HEAD

    • -13
    • +0
whitespace and spelling changes

activate warnings in case the old IE bug is still around

ad_sign: generalize last ad_sign handling to

allow user and csrf binding

use user-specific sign operations for protecting delete operations

    • -3
    • +3
ad_sign: new optional parameter "user_binding"

The parameter user_binding allows to bind a signature to a user.

When the value is "-1" only the user who created the signature can

obtain the value again. A value of 0 (default) means no user binding.

The permissible values might be extended in the future.

bump version number to 5.10.0d24

    • -2
    • +2
Bring files on oacs-5-10 in sync with HEAD

  1. … 148 more files in changeset.
Secure forums delete button by protecting the message_id with a timed signature

make sure to populate global variable for different notations of the default database

use usual spelling convention

Bring files on oacs-5-10 in sync with HEAD

add missing file

bump version number to 5.10.0d2 and update dependencies

    • -3
    • +3
bump version number to 5.10.0d23

    • -2
    • +2
parameter::get_from_package_key: check as well in "global" package parameter

and make clear, that lookup from non-singleton packages does not make


fix typos

improve comments, make function private to avoid confusions

improve comment

no need to call private function

follow usual naming conventions

    • -13
    • +13
no need to call private function of other package

Ease usage of util_memoize during startup. let util_memoize succeed,

even when the cache is not yet created

use separate urlspace for site-node cache to reduce lock contention

prefer inline SQL over generic xql to make apm code usable during initialization

new parameter "fallback_languages":

Specify space delimited two character codes for checking default languages. When this parameter is non-empty, try to get the page in the specified languages as fallback rather than offering a link for creation of a page in the requested locale. Per default this paramter is empty.

    • -3
    • +3
    • -6
    • +10
reduce redirects

    • -3
    • +3
    • -1
    • +1
whitespace and comment changes

- make sure to get rid over overdue elements from statistics

- improve comments

reflow overlong lines in comments

ad_form: Add optional parameter -csrf_protection_p (defaults to false)