• last updated 1 hour ago
Constraints: committers
Constraints: files
Constraints: dates
Add a new subsite::parameter_changed implementation for xowiki, reacting to the switching of the use_hstore parameter

This way it won't be necessary for other packages to generate the hstore manually using private api

Reinstate api as private, downstream cases need to be adapted

Make api public: downstream xowiki-like packages use it to extend uninstantiation logics

Make proc public: many downstream packages use it e.g. in their upgrade scripts

Provide a public general-comments solution to empty messages from a specific package: other xowiki-like packages downstream would otherwise need to call a xowiki private api

  1. … 1 more file in changeset.
removed leftover from debugging

    • -2
    • +0
Fix correct-when test of empty input when constraint is "<" or "<=". Many thanks for Florian Mosböck for finding this.

provide more details in log message

improve listing of test coverage

    • -0
    • +1
  1. … 16 more files in changeset.
improve listing of test coverage

    • -39
    • +45
    • -37
    • +41
  1. … 3 more files in changeset.
improve listing of test coverage

    • -2
    • +64
    • -1
    • +20
  1. … 5 more files in changeset.
use ad_proc -private

improve warning message

provide better error message

make listing of tested procs more complete

    • -14
    • +27
    • -0
    • +10
  1. … 8 more files in changeset.
Creating the site wide xowiki instance cannot half fail, as it might leave the subsite in an inconsistent state

Fixes acs-admin.acs_admin_require_site_wide automated test

form-field "range": added optional output text box for displaying the actual value

improve listing of tested procs

    • -0
    • +7
  1. … 1 more file in changeset.
avoid array notation for per_thread caches to ease flushing

  1. … 4 more files in changeset.
address issue #3460

follow naming convention as used in other places as well

start key with the package name, use array notation

  1. … 1 more file in changeset.
overhaul of formfield of type numeric

- use connection locale for localization per default

- accept always numbers in en_US

- support keeping optional the original user string (good for exams)

- use this new combination in textfields numeric type.

no need to use volatile, since these pages are marked for cleanup

in some combinations of tcl and nsf, these volatile operations might

lead to crashes

reduce verbosity, add statements to ease debugging

added new form-field type: comp_correct_when

added conjunctive answer-check

adde answer-check "contains-not"

The new form-field type offers a graphical user interface for input of

correct when clauses. When comp_correct_when is used with the repeat

flag it produces conjunctive (AND connected) clauses. The answer-check

"contains-not" is more or less the same a "contains", but highlights

such words in red.

bump version number to 5.10.0d71

use "ad_try" instead of plain "try" in include_content

make end of resub options explicit

  1. … 4 more files in changeset.
mark end of switches to improve robustness, to support '-' in word variable

fix typo: list element '1' is the upper limit

cache failed name lookups in a per-request cache (flushing maybe overly conservative)

  1. … 2 more files in changeset.