• last updated 10 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Make italian translation of "term" consistent with other occurrences in .LRN ("sessione")

Update italian localization

    • -74
    • +192
    ./catalog/dotlrn.it_IT.ISO-8859-1.xml
Add editor hints

Add 'dotlrn_club_new' test case, covering 'dotlrn_club::new', 'dotlrn_club::community_type' and 'dotlrn_community::get_community_type_from_community_id' procs

file club-procs.tcl was initially added on branch oacs-5-10.

    • -0
    • +0
    ./tcl/test/club-procs.tcl
Whitespace changes

    • -213
    • +213
    ./tcl/test/dotlrn-procs.tcl
Add trivial test 'dotlrn_community_types', covering 'dotlrn::community_type', 'dotlrn_class::community_type' and 'dotlrn_club::community_type' procs

Make api public: uses public api internally and downstream packages use it

Adapt spam variable name to what is advertised to the user

Replace spam::interpolate with 'string map'

We cannot use bind variables here, as the query is not executed at this time, but later at bulk mail sweeping

Deprecate spam::interpolate in favor of 'string map'

Reinstate get_portal_id_not_cached as private, replace occurrences with public api

  1. … 1 more file in changeset.
Reinstate get_portal_id_not_cached as private, flush the cache before calling public api instead

  1. … 3 more files in changeset.
Make api public, complies with acs-api-browser.graph__bad_calls automated test

  1. … 4 more files in changeset.
Whitespace cleanup

Make api public, complies with acs-api-browser.graph__bad_calls automated test

  1. … 1 more file in changeset.
overwork get_community_id once more. provide a shortcut is hopless situations, reduce potential warnings and improve comments

make clear that get_community_id_from_url needs connection in case no URL is provided; provide shortcut, when determined package_id is empty

  1. … 2 more files in changeset.
Fix log message, as ad_log supports only one message as argument.

Add "-url" as optional argument to "get_community_id" to ease usage in non-connection threads.

in background threads, get_community_id can be called with either the package_id,

or with the argument. Otherwise, the function is not background-safe

improve spelling

make end of options explicit

  1. … 15 more files in changeset.
add explicit cast to all max_n_rels with value null to increase readability and to ease function disambiguation

  1. … 3 more files in changeset.
Fix expression logic

Don't be so strict upstream, as here we do not restrict community_key to ltree

Constrain further the characters we allow in the community_key: makes sense upstream as this will become part of a URL, but is even more important downstream, as we implement the community_key as a ltree and therefore we are limited in the type of characters we can allow (See https://www.postgresql.org/docs/current/ltree.html)

Fix typo

Add missing arguments

Rework dotlrn_community::check_community_key_valid_p so that we check also for the community key to not have spaces

Logics have been moved to private api that might or might not become the preferrable api at some point, as it also returns the specific error message together with the boolean