• last updated 2 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
improve spelling: move closer to the linux documentation recommendations

  1. … 32 more files in changeset.
improve comments and spelling

  1. … 1 more file in changeset.
ad_urlencode_url: add a slash to the path when this is not empty, fix test case

  1. … 1 more file in changeset.
Extend test

Expose a regression after changes for bug #3437

more more fix for issue #3441

As Keith reported, there is was one more issue concerning missing column_names and empty query results. This is now as well fixed in oacs-5-10. Also, the regression test was extended to handle these cases as well.

  1. … 2 more files in changeset.
fix for issue #3441

  1. … 1 more file in changeset.
fix for issue #3437, extend regression test

  1. … 1 more file in changeset.
fix for issue #3440: problem with SQL queries in db_transactions after some db_multirows

the was a problem with with db_handle management in complex setups,

where a db_multirow iterating over more than one tuple causes

some other queries in the transaction to fail. See as well

the new test case added to the regression test.

Many thanks to Keith Paskett for reporting and the good test case!

https://openacs.org/bugtracker/openacs/bug?format=table&bug_number=3440

  1. … 2 more files in changeset.
file db-proc-test-procs.tcl was initially added on branch oacs-5-10.

    • -0
    • +0
    ./db-proc-test-procs.tcl
Use 'acs_testing' authority in 'party_procs_test' test case

Use 'acs_testing' authority in 'person_procs_test' tet case

Fallback to 'util_current_location' when 'ad_url' returns an empty string, such in cases when the SystemUrl is not set, on the util_http_json_encoding testcase

added missing editor hints

  1. … 20 more files in changeset.
Add an exception for the 'berkdb' command, defined in the global namespace by the Berkeley DB Tcl extension, to the 'naming__proc_naming testcase'

Add exceptions for some commands defined in the global namespace by the 'Trf' Tcl extension to the 'naming__proc_naming testcase'

Add xml-rpc system.* methods as exceptions in the naming__proc_naming test.

The xml-rpc package defines procs of the form system.*, that not only pollute the root namespace, but also contain the '.' character, which is not allowed by OpenACS naming standards.

The package is designed in a way that XML-RPC methods are implemented as 'ad_procs' of the same name (see package doc), and the system.* methods are standard XML-RPC methods (see XML-RPC spec). One could also expect current users of the package to have their own local 'whatever.verb' methods/ad_procs in the root namespace as well. Until future refactoring of the package to decouple XML-RPC method and proc names is done, this exception is added.

Add an exception for the operators implemented as procs in the context of the functional programming logic, on 'acs-tcl/tcl/ad-functional-procs.tcl', to the 'naming__proc_naming' test case. While some of them have names that are not compliant with OpenACS naming conventions, like '-' or '/', replacing them with other symbols is non-trivial and could make things more confusing

Add an exception for the 'dom' proc, defined in tDom, to the 'naming__proc_naming' test case

Add an exception for procs defined inside ns/aolserver modules, such as h264*, on the 'naming__proc_naming' test case

Introduce two new export_vars tests exposing that, when base URL ends with a ?, result is not what the user should expect

Relax the test by enforcing the locale from the system, rather than that from the client context

Improve test results visibility

Fix util_http_json_encoding automated test:

- fix typo

- make sure file is spooled when sampling GET request by setting max body size to 0

improve spelling

  1. … 2 more files in changeset.
Extend automated test to include also '::xowiki::Package initialize -ad_doc' idiom as a possible way to define a page contract

This has the limitation that the idiom is searched as-is... but works for upstream code

Rename string_truncate and string_truncate_middle to comply with OpenACS naming convention, create deprecated wrappers, replace occurrences

As string_truncate_middle was defined in xotcl-request-monitor, bring it to acs-tcl instead

  1. … 11 more files in changeset.
Add more borderline cases for those tempted to reimplement these procs

Move min and max procs in the util:: namespace, improve documentation, improve tests, create deprecated wrappers

  1. … 1 more file in changeset.
Rename 'random', 'randomInit' and 'randomRange' procs to something compliant to OpenACS naming convention, replace occurrences, create deprecated wrapper

  1. … 5 more files in changeset.