• last updated 17 hours ago
Constraints: committers
Constraints: files
Constraints: dates
Use security::csp::add_static_resource_header

bump version number of acs-content-repository to 5.10.1d4

  1. … 1 more file in changeset.
improve wording

Test content::item::copy

Deprecate template::util::tcl_to_sql_list, completely replaced by ns_dbquotelist, a native NaviServer command

  1. … 17 more files in changeset.
Mark api as tested

Test content::item::content_is_null public api, which has immediately found a typo

Streamline idioms

Uniform documentation style

    • -36
    • +27
Get rid of trivial private api publish::set_to_pairs

  1. … 3 more files in changeset.
Streamline ns_set idiom

improve spelling

  1. … 42 more files in changeset.
Fix typo, write a basic test for the involved api

  1. … 1 more file in changeset.
whitespace changes

  1. … 1 more file in changeset.
Fixed var name and add warning for 'cr_file_name' being empty (the latter ported from downstream, originally made by Günter Ernst)

new function: ::content::revision::export_to_filesystem

This change moves functionality from file-storage to acs-content-repository.

all application packages should be free of internals, such as the storage

type. Storage_type should be handeled in the content-repository package.

We are not yet done, there is still more to do in this respect in

the file-storage package.

    • -3
    • +10
    • -1
    • +9
  1. … 5 more files in changeset.
extend regression test

    • -7
    • +40
extend regression test

    • -1
    • +6
mark unused "content::item::get_context" deprecated, since it should be called on "acs_object"

extend regression test

remove leftover from ancient times (set it -deprecated and -private)

Piggyback some more api to existing tests

Whitespace cleanup

reduce public footprint

reduce public footprint

mark private functions as private

  1. … 9 more files in changeset.
Make api public, complies with acs-api-browser.graph__bad_calls automated test

  1. … 3 more files in changeset.
Refactor content repository backend

The refactored code is a first step to become able to provide plugins

for backends for storing content in different systems. Instead of

using switch statements to distinguish between backends "file", "lob"

and "text", procs with a suffix of the storage name are provided

now. Essentially, by providing process with additional suffixes can be

used to provide additional storage systems.

In addition, the deletion handling was also refactored such that the

non-scalable functions iterating over all items (such as

"cr_check_orphaned_files") will become obsolete. This is imporant for

content repositories with double and triple digit terabytes.

    • -15
    • +0
    • -13
    • +0
    • -5
    • +14
    • -0
    • +8
    • -10
    • +21
    • -22
    • +4
fix deprecated function

improve listing of test coverage

    • -3
    • +3
  1. … 15 more files in changeset.
make listing of tested procs more complete

  1. … 17 more files in changeset.