• last updated 7 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
*** empty log message ***

Do not override existing classes on the submit button

Many thanks to Jonathan Kelley for reporting the issue

added double-click prevention class to submit widget

move the check for the provided format on richtext level

  1. … 1 more file in changeset.
increase robustness

Inform widget: do not render any input element alongside the form value

improve spelling

  1. … 42 more files in changeset.
Fix typo

Remove duplicated code

Add new ad_form input types

  1. … 1 more file in changeset.
Use the 'search' input type in the search widget

Add new 'url' input type to 'ad_form'

Add 'template::widget::number', a widget for the form input type 'number'

Avoid sending potentially unquoted text via hidden form field

  1. … 1 more file in changeset.
address issue #3433: add option "noquote" for the "inform" widget type

The flag is currently ignored for all other widget types

  1. … 2 more files in changeset.
improve spelling

  1. … 15 more files in changeset.
Modify 'template::util::file_transform' to manage multiple files

  1. … 1 more file in changeset.
Whitespace changes

Whitespace changes

  1. … 1 more file in changeset.
ad_form: allow multiple files in 'template::widget::file' by using the 'multiple' attribute of the input tag, new on HTML5.

- Pass the 'multiple' flag to 'template::element::create', so it can be used by widgets to modify their behavior.

- Update 'template::element::create' doc.

- This opens the door to reducing the number of widgets by combining single and multivalued ones into one (for instance, 'multiselect' and 'select' widgets), in the same way the 'file' widget does now.

  1. … 2 more files in changeset.
Quote the value of the "inform"-widget value before rendering it

Quote the value of the "inform"-widget value before rendering it

Replace ad_decode idiom

  1. … 1 more file in changeset.
improve wording

  1. … 7 more files in changeset.
Revert massive replacement of empty list creation sentences. The use of '[list]' instead of '{}' adds semantics that could be used for performance improvements in the future, such as using a different internal representation. There is already work in this direction, avoiding the generation of the string representation during comparison of empty strings (huge thanks to Stefan Sobernig for the pointer: https://core.tcl.tk/tcl/info/44527c632ed609c2).

  1. … 475 more files in changeset.
modernize Tcl, improve protection against XSS

  1. … 1 more file in changeset.
Prefer '{}' to '[list]' when creating empty lists

  1. … 71 more files in changeset.
Rework variable assigning loops (set -> lassign)

  1. … 3 more files in changeset.
Fix typos

  1. … 6 more files in changeset.
Remove "catch {unset var}" idiom by "unset -nocomplain var"

  1. … 4 more files in changeset.