• last updated 8 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Improve sql portability

Replace limit (pg only) with fetch idiom, which should be portable on "modern" Oracle

Fix typo in description

Drop duplicate index 'acs_mail_lite_from_external_aml_email_id_idx'. Postgres creates automatically indexes for unique constraints and primary keys, this index duplicates 'acs_mail_lite_from_external_pkey'

    • -3
    • +1
    ./sql/postgresql/acs-mail-lite-create.sql
    • -2
    • +1
    ./sql/postgresql/acs-mail-lite-drop.sql
file upgrade-5.10.0d10-5.10.0d11.sql was initially added on branch oacs-5-10.

Whitespace changes

    • -64
    • +64
    ./sql/postgresql/acs-mail-lite-create.sql
    • -6
    • +3
    ./sql/postgresql/acs-mail-lite-drop.sql
Drop duplicate index 'acs_mail_lite_send_msg_id_map_msg_id_idx'. Postgres creates automatically indexes for unique constraints and primary keys, this index duplicates 'acs_mail_lite_send_msg_id_map_pkey'

    • -4
    • +1
    ./sql/postgresql/acs-mail-lite-create.sql
    • -2
    • +1
    ./sql/postgresql/acs-mail-lite-drop.sql
file upgrade-5.10.0d9-5.10.0d10.sql was initially added on branch oacs-5-10.

    • -0
    • +0
    ./sql/postgresql/upgrade/upgrade-5.10.0d9-5.10.0d10.sql
mprove spelling: move closer to the linux documentation recommendations

    • -2
    • +2
    ./tcl/acs-mail-lite-callback-procs.tcl
    • -4
    • +4
    ./www/doc/incoming-email-legacy-notes.adp
  1. … 17 more files in changeset.
improve wording for package parameters

add EmailDeliveryMode 'ignore'. Similar to 'log' but less verbose.

use 'ignore' in case 'redirect' is set wihout a value for EmailRedirectTo

fall back to 'log' mode, when EmailDeliveryMode "redirect" is used without "EmailRedirectTo" value

add turkish message catalog

    • -0
    • +23
    ./catalog/acs-mail-lite.tr_TR.utf-8.xml
file acs-mail-lite.tr_TR.utf-8.xml was initially added on branch oacs-5-10.

    • -0
    • +0
    ./catalog/acs-mail-lite.tr_TR.utf-8.xml
Fix parameter name in acs-mail-lite

- acs_mail_lite::send_immediately: new switch for "-force_delivery_mode"

to force delivery mode for a single call (ignoring package parameter

"EmailDeliveryMode")

- New potential value for "EmailDeliveryMode": "nssmtpd"

When this parameter is specified, the behavior is like

"smtp", but the code tries use the SMTP implementation

of the nssmtpd NaviServer module.

- It is also possible to combine "nssmtpd" with the delivery methods

"filter" or "redirect" simply by writing e.g. "filter nssmtpd"

- some refactoring to avoid repeated code

    • -51
    • +104
    ./tcl/acs-mail-lite-procs.tcl
Use optionally nssmtpd as different mail delivery agent

when the "-experimental" flag is provided to

acs_mail_lite::send_immediately, and the NaviServer

nssmtpd modules is installed.

whitespace changes

    • -42
    • +115
    ./tcl/acs-mail-lite-procs.tcl
added missing editor hints

    • -0
    • +6
    ./www/doc/incoming-email-legacy-notes.tcl
  1. … 7 more files in changeset.
Rename 'random', 'randomInit' and 'randomRange' procs to something compliant to OpenACS naming convention, replace occurrences, create deprecated wrapper

    • -29
    • +29
    ./tcl/test/email-inbound-procs.tcl
  1. … 6 more files in changeset.
Deprecate exists_and_not_null proc as it does not comply with openacs naming convention and can be replaced with plain tcl idioms

    • -2
    • +2
    ./www/doc/incoming-email-legacy-notes.adp
  1. … 3 more files in changeset.
Rename build_mime_message to ad_build_mime_message to comply with naming convention, replace occurrences, create deprecated wrapper

  1. … 5 more files in changeset.
moved "safe_eval" under the "ad_" prefix and marked the original function as deprecated

  1. … 2 more files in changeset.
improve spelling

    • -2
    • +2
    ./sql/postgresql/acs-mail-lite-create.sql
Replace deprecated api in this weird adp

    • -18
    • +18
    ./www/doc/incoming-email-legacy-notes.adp
provide proper title properties in .adp files to reduce warnings in log files

    • -1
    • +1
    ./www/doc/incoming-email-legacy-notes.adp
Prefer '==' over 'eq' on numeric comparison

  1. … 2 more files in changeset.
Keep accepting empty values as proper ids, as deprecated ad_var_type_check_integer_p would have done

replace deprecated functions ad_var_type_check_integerlist_p and ad_var_type_check_number_p

whitespace changes