• last updated 8 hours ago
Constraints: committers
Constraints: files
Constraints: dates
Whitespace cleanup

Make api public, complies with acs-api-browser.graph__bad_calls automated test

  1. … 1 more file in changeset.
overwork get_community_id once more. provide a shortcut is hopless situations, reduce potential warnings and improve comments

make clear that get_community_id_from_url needs connection in case no URL is provided; provide shortcut, when determined package_id is empty

  1. … 2 more files in changeset.
Fix log message, as ad_log supports only one message as argument.

Add "-url" as optional argument to "get_community_id" to ease usage in non-connection threads.

in background threads, get_community_id can be called with either the package_id,

or with the argument. Otherwise, the function is not background-safe

improve spelling

make end of options explicit

  1. … 15 more files in changeset.
add explicit cast to all max_n_rels with value null to increase readability and to ease function disambiguation

  1. … 3 more files in changeset.
Fix expression logic

Don't be so strict upstream, as here we do not restrict community_key to ltree

Constrain further the characters we allow in the community_key: makes sense upstream as this will become part of a URL, but is even more important downstream, as we implement the community_key as a ltree and therefore we are limited in the type of characters we can allow (See https://www.postgresql.org/docs/current/ltree.html)

Fix typo

Add missing arguments

Rework dotlrn_community::check_community_key_valid_p so that we check also for the community key to not have spaces

Logics have been moved to private api that might or might not become the preferrable api at some point, as it also returns the specific error message together with the boolean

prefer db_0or1row +"where exists" over db_string + "select case"

  1. … 3 more files in changeset.
Fix missing end

  1. … 1 more file in changeset.
Im prove sql portability

Improve sql portability

  1. … 3 more files in changeset.
Implement the 'dotlrn_applet::remove_applet_from_dotlrn' proc, called from different remove_applet procs, but never implemented

Turn the phrase around, as in other tests

Rework communities_security_inherit test: just check for existance, no need for a loop, no need to rollback anything

Whitespace cleanup

improve spelling

  1. … 6 more files in changeset.
Whitespace changes

    • -6
    • +6
improve spelling: move closer to the linux documentation recommendations

  1. … 2 more files in changeset.
Whitespace changes

Update es_ES message keys

  1. … 7 more files in changeset.
Rename ReturnHeaders proc to comply with OpenACS naming convention, create deprecated wrapper, replace occurrences

    • -2
    • +2
  1. … 9 more files in changeset.
Move rel_segments_* procs in new rel_segment:: namespace to comply with OpenACS naming convention, create deprecated wrappers, replace occurrences

  1. … 10 more files in changeset.