• last updated 7 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
added minor debugging aids, make disk-cache more similar to ns_cache

  1. … 2 more files in changeset.
Fix typos (many thanks to Nathan Coulter)

Fix typo, many thanks to Nathan Coulter

Make api public, complies with acs-api-browser.graph__bad_calls automated test

  1. … 1 more file in changeset.
avoid array notation for per_thread caches to ease flushing

  1. … 5 more files in changeset.
reduce verbosity

Prefer 'namespace which' over 'info commands', as it is faster (on local tests, around 2x) and returns a single value. Many thanks to Nathan Coulter.

  1. … 58 more files in changeset.
Whitespace cleanup

Improve sql portability

  1. … 6 more files in changeset.
Avoid the not portable limit idiom, just kill the recursive part using the flag instead

...although one should point out that Oracle does not support the boolean type...

Maintain also the has_child cache when mounting a package

Fix typo

cache method "has_children" to avoid frequent (but cheap) DB calls

introduced "ad_file" as a means to avoid unexpected tilde substitution in file names

  1. … 50 more files in changeset.
improve comments

  1. … 1 more file in changeset.
acs::per_request_cache: standardize per-request caching

- added per-request cache verfsy similar to acs::per_thread_cache

- use per-request-cache on several occasions

- bump version number of acs-tcl to 5.10.0d35

  1. … 9 more files in changeset.
fix broken dict

delete cut&pate error

added per-thread caching for "static" sitenotes. In case these will change (never saw a system where this happend), either a broadcast flush or a restart is needed.

whitespace and spelling changes

Added HashKeyPartitionedCache:

This is type of cache is like a "KeyPartitionedCache" but works as

well with strings as keys while the "KeyPartitionedCache" requires numeric

keys.

  1. … 2 more files in changeset.
flush per_request_cache also when patterns are flushed

reduce verbosity

Fix typo

fix typo

provide a better name (site_node::delete_service_nodes) amd delete nodes of services packages as well

  1. … 1 more file in changeset.
bugfix: unmounting a package could lead to a deletion of services used in other packages

A new API call "site_node::unmount_services" can be used to unmount all services in a first step.

unmount services before calling "site_node::delete -node_id $node_id -delete_subnodes -delete_package"

prevents collateral damage.

  1. … 3 more files in changeset.
improve spelling

  1. … 15 more files in changeset.
improve spelling

  1. … 3 more files in changeset.
add checking for javascript and data protocols (fixes issue #3413)

  1. … 3 more files in changeset.