• last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
we already have the package_id

first draft

    • -0
    • +23
    /openacs-4/contrib/packages/simulation/simulation.info
    • -0
    • +23
    /openacs-4/packages/simulation/simulation.info
Reverting accidental change

Cleaned up code to get the category list

Applied fix from Carsten Clasohm - now upgrade works on pg7.3 as well (tried it on 7.2 too). Fixes #631

Re-create the table with different constraint names than it had before, so they won't collide. Also tried renaming the constraints but that didn't work. Fixes #616

Making emoticons switched on by default again, Lars accidentially committed default false.

    • -1
    • +1
    /openacs-4/packages/forums/forums.info
A bunch of I18N fixes for acs-subsite. More to follow.

Use a multiselect instead of a table with checkboxes, which makes the UI work a little bit better when there are lots of privileges.

Added missing I18N key.

A few more I18N tags added to login-status.adp.

Gave site-master.* the I18N treatment. Added a workaround, so the

'Your Account' can both be named as a kernel parameter, or have a proper

translation key.

Added I18N message keys for site-master.adp.

Fixing an error in the join clause of the party_search widget which resulted in returning way too many, and redundant matches.

Added an introduction how to setup bouncing with postfix

updating README and TODO files. Bugfixing dotlrn-basic-setup

    • -12
    • +2
    /openacs-4/etc/install/tcl/twt-procs.tcl
    • -8
    • +4
    /openacs-4/etc/install/tcl/user-procs.tcl
taking action on lost gl_ES messages (http://openacs.org/forums/message-view?message_id=133859). The messages had ended up in message files with locale utf-8 (don't know why yet). Moving the messages back to ISO-8859-1 files and removing the utf-8 files

  1. … 15 more files in changeset.
taking action on lost gl_ES messages (http://openacs.org/forums/message-view?message_id=133859). The messages had ended up in message files with locale utf-8 (don't know why yet). Moving the messages back to ISO-8859-1 files and removing the utf-8 files

adding syntax check of acs-lang.localization-grouping value and falling back on en_US locale in case of invalid syntax (to avoid broken pages)

bugfix: forgot to wrap the site-wide-admin-toggle link in a dotlrn_user_p if statement in my last commit

    • -7
    • +9
    /openacs-4/packages/dotlrn/www/admin/user.adp
removing old procs file replaced by files in tcl dir

    • -873
    • +0
    /openacs-4/etc/install/tclwebtest-functions.tcl
adding a simple forums posting test. Restructuring procs a little

    • -15
    • +15
    /openacs-4/etc/install/dotlrn-basic-setup.test
    • -4
    • +4
    /openacs-4/etc/install/tcl-api-test.test
    • -0
    • +63
    /openacs-4/etc/install/tcl/config-procs.tcl
    • -3
    • +3
    /openacs-4/etc/install/tcl/news-procs.tcl
    • -2
    • +2
    /openacs-4/etc/install/tcl/test-procs.tcl
    • -0
    • +170
    /openacs-4/etc/install/tcl/twt-procs.tcl
    • -17
    • +28
    /openacs-4/etc/install/tcl/user-procs.tcl
    • -164
    • +0
    /openacs-4/etc/install/tcl/util-procs.tcl
the toggle-site-wide-admin link was duplicated, removing one of them. Indenting the bottom link section

    • -26
    • +11
    /openacs-4/packages/dotlrn/www/admin/user.adp
posting message in forums broken because attach_p was empty string, see bug 932. Temporarily fixed.

    • -2
    • +2
    /openacs-4/packages/forums/www/message-post.tcl
further adaption of install.sh to the new OpenACS installer. Making dotlrn-basic-setup work with new tcl library

    • -1
    • +1
    /openacs-4/etc/install/tcl/news-procs.tcl
    • -1
    • +1
    /openacs-4/etc/install/tcl/user-procs.tcl
    • -1
    • +1
    /openacs-4/etc/install/tcl/util-procs.tcl
making dotlrn-basic-setup use the new namespacified procs

    • -46
    • +46
    /openacs-4/etc/install/dotlrn-basic-setup.test
    • -15
    • +8
    /openacs-4/etc/install/tcl/news-procs.tcl
    • -7
    • +11
    /openacs-4/etc/install/tcl/test-procs.tcl
    • -31
    • +22
    /openacs-4/etc/install/tcl/user-procs.tcl
    • -6
    • +17
    /openacs-4/etc/install/tcl/util-procs.tcl
breaking up the procs to support testing OpenACS with tclwebtest into namespaces.

    • -0
    • +91
    /openacs-4/etc/install/tcl/admin-procs.tcl
    • -0
    • +164
    /openacs-4/etc/install/tcl/class-procs.tcl
    • -0
    • +175
    /openacs-4/etc/install/tcl/dotlrn-procs.tcl
    • -0
    • +32
    /openacs-4/etc/install/tcl/forums-procs.tcl
    • -0
    • +35
    /openacs-4/etc/install/tcl/global-vars.tcl
    • -0
    • +73
    /openacs-4/etc/install/tcl/news-procs.tcl
    • -0
    • +15
    /openacs-4/etc/install/tcl/test-procs.tcl
    • -0
    • +220
    /openacs-4/etc/install/tcl/user-procs.tcl
    • -0
    • +153
    /openacs-4/etc/install/tcl/util-procs.tcl
Processes now work pretty well. There is a bug in the dependency code

for tasks now that prevents dependencies from being used.

  1. … 8 more files in changeset.
get rid of the annoying and potentially incorrect leading space when returning parsed templates.

Fixed bug #442: Confirm doesn't really let you change your mind nicely

    • -66
    • +72
    /openacs-4/packages/forums/www/message-post.tcl