• last updated 13 mins ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
prefer dict over array

Qualify 'callback' proc in the global namespace, lest it might conflict with 'subsite::callback'

Reduce divergency between oracle and postgres codebase

  1. … 2 more files in changeset.
Move rel_segments_* procs in new rel_segment:: namespace to comply with OpenACS naming convention, create deprecated wrappers, replace occurrences

  1. … 10 more files in changeset.
improve spelling

  1. … 6 more files in changeset.
whitespace changes

  1. … 51 more files in changeset.
whitespace changes

  1. … 9 more files in changeset.
improve spelling

added more TODOs to half-finished (?) function subsite::pivot_root

added "create_or_replace" flag to subsite::new_subsite_theme

This feature is similar to the "create or replace" idiom for updating

SQL functions and eases the update of standard themes

  1. … 1 more file in changeset.
Port from downstream: reimplement subsite::get_theme_subsites to be scalable on websites with many site nodes

follow usual naming conventions

  1. … 2 more files in changeset.
Remove unneeded variable

Move remaining portable queries to tcl file

  1. … 1 more file in changeset.
Streamline retrieval of mapped host nodes

  1. … 3 more files in changeset.
Move query into tcl file

  1. … 1 more file in changeset.
Avoid setting the whole array in the api and just return what we need

Avoid asking for an array in the api

Use api and portable idioms to reduce divergency between oracle and postgres codebase

  1. … 2 more files in changeset.
Replace queries with api and already available information

  1. … 1 more file in changeset.
improve spelling

  1. … 8 more files in changeset.
Fix parameter names in proc doc

  1. … 2 more files in changeset.
Harmonize parameter names in proc documentation removing unexistent ones

Streamline sql to reduce divergencies between oracle and postgres codebase, remove redundant query definitions

  1. … 3 more files in changeset.
Revert massive replacement of empty list creation sentences. The use of '[list]' instead of '{}' adds semantics that could be used for performance improvements in the future, such as using a different internal representation. There is already work in this direction, avoiding the generation of the string representation during comparison of empty strings (huge thanks to Stefan Sobernig for the pointer: https://core.tcl.tk/tcl/info/44527c632ed609c2).

  1. … 475 more files in changeset.
make spelling more consitent

  1. … 2 more files in changeset.
Prefer '{}' to '[list]' when creating empty lists

  1. … 71 more files in changeset.
Prefer string comparison operators to 'string equal' and 'empty_string_p'

  1. … 5 more files in changeset.
fix typos

  1. … 7 more files in changeset.
Fix typos

  1. … 42 more files in changeset.